Jump to content

Stuck on Download


Vadgoel

Recommended Posts

Set the compatibility mode on the launcher to Windows XP Service Pack 3.

Right mouse click on the game shortcut, select properties.

Click on the compatibility tab, you will see a tick box for run this program in compatibility mode. Select Windows XP Service Pack 3.

tick the run as admin box

Click apply and then ok.

 

 

you can also install though steam or switch to non streaming per https://answers.ea.com/t5/Troubleshooting-Guides-Info/Guide-How-to-Switch-to-Non-Streaming-Launcher/...

 

that will also fix this issue if the above doesnt help

 

 

Found this in a support forum and it worked for me

Link to comment
Share on other sites

I too am having the same issue. I tried the fix suggested above, but I don't seem to have a compatibility tab to change....any suggestions?? I've had this happen before, but usually I just log out , close the game, and then log back in and it works normally after that, but not this time.

 

OK the above fix does work but it's explained more accurately here.

07.20.2020 , 05:00 PM | #6

REPORT POST QUOTE

The work around that actually works 100% of the time and doesn’t require you to download the game again.

 

Find the launcher.exe file in your swtor game folder.

Right click it and go to properties

Find the compatibility mode setting and select Windows XP SP3. Click apply and close.

 

Now when you launch the game it won’t get stuck in quick play mode.

 

To find the launcher.exe file... click on the following things..

Drive where your game is installed.

Program files (x86) folder

Electronic Arts folder

BioWare folder

Star wars - the old republic folder

Right click the launcher icon

Follow the previous instructions stated above.

May The Force Be With You!!!

Edited by DJVanBeers
Link to comment
Share on other sites

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.