Jump to content

Anyone Play at 4k on LG C2? I have scaling issues


Zergnaut

Recommended Posts

Does anyone play this game on the LG C2 at 4K resolution? I have all the settings correct and the resolution set to 4K. On the LG C2 my characters look squished like extra skinny.

I swapped to another 4k monitor and they look perfect then I go back to the LGC 2 and I have the same problem has anyone found a fix for this or know what could be causing it?

 

This only happens in SWTOR though all my other games are perfectly fine and do not experience this issue whatsoever

Edited by Zergnaut
Link to comment
Share on other sites

  • Zergnaut changed the title to Anyone Play at 4k on LG C2? I have scaling issues

EDIT: Found out on REDDIT that apparently SWTOR unlike most games reads the Monitor's EDID file instead of what your "active display setting by your GPU".  Currently looking for a way around this.  

Once again in the meantime if you got it working flawlessly please share what you did.

Link to comment
Share on other sites

There are different definitions of "4K".  I use "4K" screens that are nevertheless 16:9 (UHD == 3840x2160), and they work just fine.  The EDID thing isn't *exactly* what you think it is, either.  SWTOR uses that, sure, but the problem ends up being the screen's fault, since its EDID reports a fictional mode, often 16:9) that's higher-enough to accommodate the larger of the width or height of the screen, which means it's not the same aspect ratio as the screen.  SWTOR uses the highest-resolution mode in the EDID data to decide the aspect ratio it will use, so it uses that fictional mode rather than the native mode, and gets the aspect ratio wrong.

The various workarounds you'll find all rely on the fact that SWTOR doesn't read the EDID data from the *monitor*.  It reads it from the configured "driver" for the monitor, and that can be faked up to not have the fictitious mode.

Link to comment
Share on other sites

On 2/1/2023 at 5:28 PM, Zergnaut said:

EDIT: Found out on REDDIT that apparently SWTOR unlike most games reads the Monitor's EDID file instead of what your "active display setting by your GPU".  Currently looking for a way around this.  

Once again in the meantime if you got it working flawlessly please share what you did.

Use CRU https://www.monitortests.com/forum/Thread-Custom-Resolution-Utility-CRU and set default resolution and frequency , otherwise can also try connecting the monitor via displayport / HDMI etc depending on what your using already

Link to comment
Share on other sites

UPDATE: Found the solution. On reddit of all places.

I have a temp fix: I had to use CRU to delete a resolution above 3840 x 2160 which was saved the EDID. Both 3840 x 2160 and 4096x2160 were showing as "active" at the same time. I deleted the 4096x2160 resolution from "TV Resolutions" and "HDMI supported formats" now and it works flawlessly.  

Permanent Long Term Fix: The issue only happened with the HDMI port. Not the Display port.  Plugged a 4k monitor this did not happen on into the HDMI port and it happened with it too. Sadly my LG C2 does not have a display port so I was FORCED to use HDMI or I would have just plugged it into my display port and called it a day. I bought a one way directional Display Port 1.4 to HDMI 2.1 adapter for my LG C2. When it arrives I will restore what I deleted and plug the C2 into my Display port on my RTX 4080 instead of the HDMI port.

Edited by Zergnaut
Link to comment
Share on other sites

1 hour ago, OwenBrooks said:

Use CRU https://www.monitortests.com/forum/Thread-Custom-Resolution-Utility-CRU and set default resolution and frequency , otherwise can also try connecting the monitor via displayport / HDMI etc depending on what your using already

Steps on how to change the default resolution in CRU?  I will undo what I did and do that instead. I exported a backup to reset to before I made any changes.

Like I said above I had to delete 4096x2160 resolution from "TV Resolutions" and "HDMI supported formats". I can restore the backup and just change the default if you explain a little more

Edited by Zergnaut
Link to comment
Share on other sites

4 hours ago, Zergnaut said:

UPDATE: Found the solution. On reddit of all places.

I have a temp fix: I had to use CRU to delete a resolution above 3840 x 2160 which was saved the EDID. Both 3840 x 2160 and 4096x2160 were showing as "active" at the same time. I deleted the 4096x2160 resolution from "TV Resolutions" and "HDMI supported formats" now and it works flawlessly.  

Permanent Long Term Fix: The issue only happened with the HDMI port. Not the Display port.  Plugged a 4k monitor this did not happen on into the HDMI port and it happened with it too. Sadly my LG C2 does not have a display port so I was FORCED to use HDMI or I would have just plugged it into my display port and called it a day. I bought a one way directional Display Port 1.4 to HDMI 2.1 adapter for my LG C2. When it arrives I will restore what I deleted and plug the C2 into my Display port on my RTX 4080 instead of the HDMI port.

OK, that's good news.  Thanks for coming back and letting us know how you got it going.

Link to comment
Share on other sites

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.