Jump to content

SideWinder Mouse - Keybinding


Demonsguile

Recommended Posts

I have a SideWinder X8 mouse. This mouse comes with two "thumb" buttons, upper and lower. Typically, I use the 'Microsoft Mouse - Intellipoint' software to map the lower button as "Ctrl" and the upper button as "Alt". In that way, I'm able to keep my left four fingers on the keyboard buttons 1 - 4, but have access to 12 different options.

 

Unfortunately, the mapping doesn't seem to be working for SWTOR. It does work outside of the game, though. This is going to make it very difficult for me to play effectively.

 

Things I've tried:

1. Verified that my mouse driver is up-to-date.

2. Made the Microsoft Mouse program run as Administrator.

3. Changed the compatibility mode to each available option.

 

I'm using Win7 64-bit, if it makes any difference.

 

Help would be GREATLY appreciated.

 

Thanks,

DG

Edited by Demonsguile
Link to comment
Share on other sites

For Christmas, I'd like nothing more than a developer, forum moderator, or even a janitor who works for BioWare to reply to my post telling me either:

A. This is a supported feature and the problem is on the client side (ie, it's my problem).

B. Mapping a keyboard button is an unsupported feature within SWTOR, and quit trying.

 

Please Santa, have someone reply to me with a quasi-"official" answer.

This is driving me insane.

 

Thanks,

DG

Link to comment
Share on other sites

Same problem here. I bought a new mouse for the game but can't get the buttons to work. Hopefully this will be available soon.

 

I do love the idea of using a mouse button for CTRL or SHIFT. I hadn't thought of but it's a tremendous idea!

Link to comment
Share on other sites

It seems to be an issue with the mouse not being able to pass unusual key strokes to the game. The problem isn't just limited to SWTOR, I've had issues binding mouse keys on other programs too.

 

I use a Razer Lachesis, and I fixed it by running all the razer mouse driver .exes in admin elevation. For me, this was in the folder C-->Program Files (x86)-->Razer-->Lachesis

 

The idea is that the mouse drivers need to be ran at admin rights. I didn't know which one was the mouse driver so I just elevated all the .exes in that folder.

 

I'm just speculating on why this works. People have also suggested disabling UAC completely and that seems to work for some people. So I assume it's permission related issues with keystroke passing.

 

Previously I could only bind mouse1-mouse5 + scrollup/down in game. Now I have keys bound to Ctrl+5, 'a' and 'd' and it seems to work fine.

 

I have noticed that I've gotten UI freezing bugs since I did the re binding, but I rebinded almost all the keys in the game so I dunno if this is the cause of it :S I hope not. But if this works for you, and you get UI freezing bugs too... let me know?

Link to comment
Share on other sites

I'm running Windows 7 64-bit and I got Inellipoint to work by changing the privilege level settings of C:\Program Files\Microsoft IntelliPoint\iPoint.exe to run as an administrator. Everything seems to work fine. I'm not even getting the UI issue.

 

Thanks Guys

Link to comment
Share on other sites

Hey guys,

 

There are a lot of threads cropping up on this topic. Currently there are very few solutions to your problems. My suggestion would be to create a new thread in the suggestion forum regarding the use of key bindings.

 

I'll link you to a post I made previously with two suggestions that have worked for others and may assist you in your endeavors.

 

Regards,

Tenneth

 

 

Link: http://www.swtor.com/community/showthread.php?p=345128#post345128

Link to comment
Share on other sites

I'm running Windows 7 64-bit and I got Inellipoint to work by changing the privilege level settings of C:\Program Files\Microsoft IntelliPoint\iPoint.exe to run as an administrator. Everything seems to work fine. I'm not even getting the UI issue.

 

Thank you thank you thank you thank you thank you thank you.

Link to comment
Share on other sites

×
×
  • Create New...