Jump to content

New SWTOR Forums are now live! ×

Ancient Force-Imbued Blade Sheath Bug


Momo-chan
 Share

Recommended Posts

Hi,

 

recently noticed this bug. When equipping the Ancient Force-Imbued Blade as a dual wielder, they're put on my characters back. The blades appear with their sheaths in the right place. However, as soon as I enter any kind of scripted sequence or cut-scene, the sheaths disappear from the back of my character and when the game continues, the sheaths are stuck together, floating slightly above the ground behind my character.

The character in this case is a Sith Worrior, wearing the Resiliant Wardens Armor Set as an outfit.

 

Edit: when I un- and re-equip the blades, the sheaths are back where they should be - until the next cut-scene...

 

Cheers

Edited by Momo-chan
Link to comment
Share on other sites

  • 4 months later...

The sheath doesn't even show on me anymore when I switch my combat style.

I'm not even sure if that counts as part of the same bug or something maybe introduced in 7.0 as another bug.

Could someone please please please look into this and get back on the tracker? Thank you for your time bioware much love :D

Link to comment
Share on other sites

/bump

 

Bug has neither been acknowledged nor fixed after over 4 months.

 

Sadly it has been a lot longer than that, and also issues with off-hand holsters disappearing. It is a shame to see the bugs persist considering the chunky CCs the pieces have cost each of us.

Link to comment
Share on other sites

 Share

×
×
  • Create New...