Jump to content

Unexpected error when using a referral link


Acyed

Recommended Posts

Hello, subscribers or f2p players who use my referral link gets an unexpected error. It has been like this since i resubbed with 60 days of game time through steam. I have tried with almost 40 people and every one of them got the same error. Anyone who knows the solution ?

 

P.S: Trying from a different browser or waiting 7 days after resub did not work

 

EDIT : It fixed itself when my sub lapsed ( when i got 500 cc as sub reward exactly )

Edited by Acyed
Link to comment
Share on other sites

Hello, subscribers or f2p players who use my referral link gets an unexpected error. It has been like this since i resubbed with 60 days of game time through steam. I have tried with almost 40 people and every one of them got the same error. Anyone who knows the solution ?

 

P.S: Trying from a different browser or waiting 7 days after resub did not work

 

what does the error say? Did you copy the link from the site, or just write it down, if you write it down, is it exactly as it is on screen.

Link to comment
Share on other sites

After the yes/no option. They have all emails enabled and requirements, but still showing the message. Im certain its bugged (note that I tried with a lot of different people, not only one)

 

 

did you put in a /bug report, and a thread in the bug forum. Does no harm in doing both. Also mail support@swtor.com, they might just say you have to send in a bug report, but they also might be able to give you information on whether it's being looked in to.

Link to comment
Share on other sites

did you put in a /bug report, and a thread in the bug forum. Does no harm in doing both. Also mail support@swtor.com, they might just say you have to send in a bug report, but they also might be able to give you information on whether it's being looked in to.

 

I did all what you mentioned. The normal answer they give is "make sure he has enabled email from EA" ...When my explanation is "He has emails enabled and havent done it in years, or is first time even". Support on this game is a joke

Link to comment
Share on other sites

  • 3 weeks later...

Sorry if this is incorrect thread but maybe you guys can help me sort things out.

So the game came out on Steam right? And it seems to automatically link your steam account with swtor.com one when you launch the game.

 

My question is, could this be the case for referral not working properly? Cuz the colleague of mine wanted to try ot the game, used my referral. In both his and mine page it says that the link has been used successfully, yet he didnt get his sub days and in-game bonus rewards.

Edited by Antonitze
Link to comment
Share on other sites

Sorry if this is incorrect thread but maybe you guys can help me sort things out.

So the game came out on Steam right? And it seems to automatically link your steam account with swtor.com one when you launch the game.

 

My question is, could this be the case for referral not working properly? Cuz the colleague of mine wanted to try ot the game, used my referral. In both his and mine page it says that the link has been used successfully, yet he didnt get his sub days and in-game bonus rewards.

 

both of you have to mail support@swtor.com, and see if they can help.

Link to comment
Share on other sites

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.