Jump to content

Player Ghosts


Recommended Posts

We've noticed a problem with the /who panel happening for several weeks now. I mentioned it during today's server event and had a couple of people in other guilds saying it happened to them as well. We haven't been able to work out a cause for this but all show the same problem which is that some characters get stuck in /who searches so they never go offline there. Here are three that we have at the moment.


This is someone that we banned from guild. Searching for the guild name or their character name shows they are still in guild. This one also shows them on Imperial Fleet (3) when at the time of the screenshot there were only 2 instances:




This is someone who is in guild and has played on other characters but as you can see the one in question has not been played for 5 days but still shows up in /who searches:




This is one where the character is actually online so they show up twice, one is the old ghost and the other is the online version:




I've asked around and it turns out several people know about this and the two things they all agree on are:


1) The people are always shown to be on fleet

2) They only get removed from the /who searches when there is a server restart


It's not game breaking but it has confused a few people who are trying to find a guild member to get an invite and at least 3 of the results in the /who search are ghosts that can't reply.


Has anyone else come across this issue and worked out what triggers it?

Link to comment
Share on other sites

We're on the Darth Malgus server, which are you on if you have seen it happening as well?


I suspect that the thing about them being on fleet is just coincidence. Need more ghosts to really get a better idea of that.

Edited by UlaVii
Link to comment
Share on other sites

It’s been happening to me when I’ve tried to go into dxun operation via group finder.


Happened twice to me this afternoon.


First time before the servers went down and after about 1800 gms. First time was on onderon and second time I was on ilum.


I couldn’t chat at all either in guild or general.


Tried logging out and also tried restarting my laptop, when back in I was no longer in my guild but can see members logging in and logging out.


I hope this is sorted soon and helps

Link to comment
Share on other sites

The problem has happened multiple times today both before and after the backend maintenance. It manifested itself today by bugging out in group finder twice.



  • They queued for the daily group finder raid as a group
  • When it popped and they loaded in they were each in separate raids on their own
  • They all exited the raid and that's when the bug kicked in
  • Location does not seem to be a factor as some of them were scattered around the galaxy when they queued


Everyone who was in any of the groups that the bug happened to found to their alarm that they had been removed from guild and had their subscriptions cancelled. These characters also became ghosts so they show up in /who searches even when they are not online. They have not actually been removed from guild as I can see them in the roster still but the game tells them they are not in guild and they are unable to access the roster, flagship, guild chat or other guild assets.


Some people were able to resolve it by closing the game and reloading. Others were not able to resolve it and just gave up trying and went to play other games.


Since SWTOR is telling them all they are Free To Play they can't even submit bug reports. I think all have been able to get back their subscription status and for the game to allow them access to the guild again but for some it took a very long time and there appears to of been nothing they could do to force the problem to be solved e.g. quitting and reloading did nothing.


Even once they got access back it still shows several new ghost characters with a who search: https://i.imgur.com/H7IxvEg.jpg


Here are some quotes from the people affected which I got from screenshots, private messages and our Discord:


GF just bugged out, when we relogged we were all out of guild

Loads of Ghosts in guild now, created 7 in 1 ops grp


When we try to queue

each time it dumped a single person into the instance in a group just by themselves, and the other 7 got bugged


relogging kicked me from the guild what!

me too

*** is is this gaaaame

Shows me as unguilded as well but I can still see people logging in and out of the guild xD

closed game, trying it from launcher

nope not even full relaunch works..

same for me

gg bioware

weird thing is all our toons are still in the guild according to the list


Ermmm I’m not in a guild now :cry:

Red text showing account converted to Free To Play: https://cdn.discordapp.com/attachments/470611516278702081/672130071103930369/bug.PNG

get that when i try to talk in ANY channel

& have 6 months sub

As do I. Lovely.


Im writing and nothing can be seen

have you restarted the game already?



Strongholds are gone. Can't access legacy cargo. gg

its like they lost all account info, showing me as a brand new FTP but still have characters


Should i even log in ?


happend before to me, got kicked from gf ops, then it showed me as unguilded and i couldnt whisper anyone cuz they were "not in my faction", also showed me as non sub on char screen. Had to restart game few times to fix it xd but it was only on that one char xD

Really weird bug, but no idea what causes it


relog ****ed it up again like before


I was talking to someone else about this and they said that it bugs you for 15 minutes. Everything should be back by then if you restart


Won't have time to retry by then. Maybe next time. GLHF


aaaaaaaaaaaan now im not in guild!

i was just afk you didnt have to kick me out of the guild :smile:



Bloody game....I’m not in a guild again :rage: I’ve quit the game and restarting my laptop

ive restarted my laptop and still the same

Link to comment
Share on other sites

This happened to me yesterday twice once before & once after reset, we formed a group for group finder, once everyone had hit accept 1 person in the group was transported to the Dxun operation & the other 7 in the group were just removed from the party. All 8 could then do nothing, we could not reform the group as it said we were free to play even though all of us had subs, the person inside the Operation was in there solo & could not leave. The only option for us was to relog all the way out of the game, when we came back our guild tags, strongholds & legacy banks were gone, our conquest points were reset to zero & we could not chat because of the restrictions to free to play. We then all relogged out of the game again, when we returned from the 2nd relog everything was back to normal apart from a "Ghost" of every player appearing in the /who window.
Link to comment
Share on other sites

More complaints from another ops group that got bugged today. Same thing; Group Finder daily op messing with people's subscription status and guild access. It also created more ghosts:


everyone accepted, timer still timed out and sat at zero, everyone but person with lockout and one rndom person landed in a fresh instance not lockout instance, and the last person just never got to travel and had to restart game, the got teh guildless status, the restart again fixed it


[about game switching people to F2P status] you dont get a message but if you try to use any chat channel you get a "F2P cant use" server message


I think the group finder bug is a separate issue that just happens to also create ghost characters as at least 2 of the people from my first post became ghosts when the game crashed.

Link to comment
Share on other sites

It's not exactly something new, my guild had this happen to us before 6.0 though since Tulak Hord as a whole was acting weird those days we didn't report it as a bug. Same scenario, guild group trying to do GF operation but instead of zoning in, some were able to get inside and for them the others were still in the group and guild but the rest couldn't chat or see anything of that nor travel anywhere.

As far as we found out, a work-around to get all that working again, if restarting the game doesn't help, is to log into a character on another server.

It may act out there too, I suddenly was in guild of the character I last logged in on TH while being on a new character on DM, but logging back into Tulak Hord, chat was working again and the rest too as far as I remember, there just was that ghost clone of my character online until the next server restart but it didn't impact me playing.

Link to comment
Share on other sites

Hey thanks for the suggestion. I'll drop it in our Discord so guild members know about it.


To be honest, this whole thing has really put people off queuing for Group Finder ops. Guess we just got lucky that it only started affecting us recently. You're not the only person to say this has been going on for months and hearing that has really torn people. We had hopes that the server maintenance would put an end to it but the fact it happened again within an hour or two of the servers coming back online and then the day after as well really makes it hard to have faith in the developers. Guild interface broken. Conquest broken. Crafting broken. Mats storage broken. Gearing broken. Group Finder broken. Customer services broken. :(


Come on EA/Bioware, we all know you can do better than this. Please help your players play the game.

Link to comment
Share on other sites

No, no no! Do not complain about the bugs that riddle this game. We need new content! New CONTENT!


This was sarcasm.


One of the next 6 point whatever needs to be a huge bug fix. But, again, new content is much more important than a working game.

Link to comment
Share on other sites

Happened again tonight with Scum & Villainy in Group Finder. Here's the chatter from Discord:


G: guild kicked bug is back

F: game says im not subbed.

G: yeah, im not in guild on spell. Still a sub though

F: logged frank and when i type in /1 it says i cant since im not subbed.

B: yeah, how do you fix?

S: Wait till the "i left gf timer" runs out. Like 10 15 mins. Then restart game once or twice. Tho this is not a guaranteed fix i thought

B: back to normal

F: did you relog or restart?

B: 2 quits

S: Enjoy your ghost brothers btw


So another 8 people all temporarily lost their subscription status and guild access. We currently have at least 13 ghosts for one of our guilds. An additional consequence of this is that new people trying to join the guild are going to have a hard time contacting someone for an invite when they keep getting "Character is not online" when they attempt to /w.


Come on Bioware, fix this. I know you can do better. I keep saying that. Please start proving I'm not wrong.

Link to comment
Share on other sites

  • Create New...