Jump to content

Imperial Agent Class Mission Bug


Jakk_Windspyre

Recommended Posts

The first two paragraphs can be skipped unless you want more details.

 

I've been playing SWTOR for almost two years now, and I adore the game. About three months ago, I returned after taking a break, and played the new expansion on my completed characters. Now with the 250% EXP Boost, I decided I was going to attempt to finish the classes I never got to. I was doing well. I took out the first three easily. Then Imperial Agent came.

 

Despite all the great things I had heard about the Imperial Agent class, and my admitted bias toward the Imp faction, I never bothered to try it. It didn't look all that appealing. Obviously, I was wrong. In a matter of hours I beat the prologue. I was ready to continue and hyped to do so.

 

Then the issue occurred. I had just finished my mission on Korriban ("Darth Zhorrid Arrives"). I took a shuttle back to my ship. It told me to use my holoterminal. When I activated it, there was a pause. When the dialogue finally finished loading, all that could be seen was a distant hologram of Watcher Two looking down at my character. No one said a word, no "choice wheel" (I think that's what you call it?), and I couldn't do anything. When I pressed escape, the conversation ended.

 

I tried EVERYTHING. I moved planets. Nope. I left my ship. Ha, no. I reset the phase. Nothing. I reset the entire freaking mission. You guessed it, didn't work. I did some research and apparently other players had the same problem. Unfortunately I never got a valid answer as to what to do. People have tried making a new character, and had the same issue at the exact same point in the story. Re-installing doesn't help either. It seems attached to my account.

 

I never got a response on my In-Game support ticket. This has never happened to me before and it's getting on my nerves. I really want to play this class because of all the good reviews on it. No other character on my account has had this problem either. I don't know what to do about it anymore. Any help, advice, or feedback would be helpful.

Link to comment
Share on other sites

I had that issue a long time ago. (My recent playthru worked fine). Unfortunately I only got past that point after submitting an in game ticket, and they pretty much just bumped me past that conversation. It took a few days to get a response also.

 

Thank you for the feedback. I'll just have to wait for them to bump me past the conversation.

Link to comment
Share on other sites

There is one other thing you can try. I've seen other reports of folks getting "stuck" in conversations (though maybe not this one), and the workaround was to put all your graphics on the lowest settings before starting the conversation. May or may not work for you, but if it does, it will save you waiting around for days for a CSR to bump you forward. If you're using "custom" settings, be sure to make a note of what your settings are, so you can put them back afterwards.
Link to comment
Share on other sites

There is one other thing you can try. I've seen other reports of folks getting "stuck" in conversations (though maybe not this one), and the workaround was to put all your graphics on the lowest settings before starting the conversation. May or may not work for you, but if it does, it will save you waiting around for days for a CSR to bump you forward. If you're using "custom" settings, be sure to make a note of what your settings are, so you can put them back afterwards.

 

It worked! Thanks for your help. That was really starting to bother me.

Link to comment
Share on other sites

  • 2 years later...
There is one other thing you can try. I've seen other reports of folks getting "stuck" in conversations (though maybe not this one), and the workaround was to put all your graphics on the lowest settings before starting the conversation. May or may not work for you, but if it does, it will save you waiting around for days for a CSR to bump you forward. If you're using "custom" settings, be sure to make a note of what your settings are, so you can put them back afterwards.

 

This issue is STILL HAPPENING and that fix isn't working... the customer service agent suggested it when it happened the first time... they need to just fix this issue instead of feeding us "enduser issue" garbage... if you dont know, devs, then say you dont know FFS!

Link to comment
Share on other sites

This issue is STILL HAPPENING and that fix isn't working... the customer service agent suggested it when it happened the first time... they need to just fix this issue instead of feeding us "enduser issue" garbage... if you dont know, devs, then say you dont know FFS!

The "set your graphics to minimum" thing works for people who have machines that are *now* below the minimum system requirements but which were OK, just, when the game released.

 

Despite widespread claims by grumpy forumites that there have been no changes in the graphics, there have, indeed, been various improvements, but every single one of them has increased the "true" system requirements (notably in terms of dedicated graphics-card memory), and now those old PCs aren't up to the job any more, and one place that it shows up easily is certain cinematics, often involving some sort of holoterminal.

 

That's why the end-user workaround is suggested - it's much cheaper for the end-user than buying a better PC.

 

Clearly that's not 100% of the answer, but it's a big part of it.

Link to comment
Share on other sites

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.