Jump to content

Pro tip: Windows 10 and graphic issues.


CKNORTH

Recommended Posts

It's interesting that for years I was running this game getting a lot of stutters in graphics, shadows would cause problems etc etc. So it dawned on me that I should run a Windows test for combattability (sp) It found that this game needs to run on Windows 7 only. So I adjusted my windows and now the game runs as smooth as butter...

 

Anyhow I thought I should share, hopefully anyone having issues try's this Windows test, oh and I am running on optimum settings too! :)

Link to comment
Share on other sites

Just to add to the OP tip about using compat mode , as compat modes if applied differently to launcher.exe and swtor.exe can cause issues. (they need to be using identical compat mode)

 

Simply try playing in fullscreen window mode if have stutters, this should fix the stutter issue

 

Also If using Nvidia card make the following change to the swtor.exe profile

 

go to "manage 3D settings" > "Program Settings" > "Add" (find the swtor.exe from the installed directory)

> "Maximum pre-rendered frames = 1" <--- is the important setting

> "Multi-display/mixed-GPU acceleration = Single display performance"

> "Power management mode = Prefer maximum performance"

> "Triple buffering = ON".

The rest of the settings should be left as Default.

Edited by OwenBrooks
Link to comment
Share on other sites

Just to add to the OP tip about using compat mode , as compat modes if applied differently to launcher.exe and swtor.exe can cause issues. (they need to be using identical compat mode)

 

Simply try playing in fullscreen window mode if have stutters, this should fix the stutter issue

 

Also If using Nvidia card make the following change to the swtor.exe profile

 

go to "manage 3D settings" > "Program Settings" > "Add" (find the swtor.exe from the installed directory)

> "Maximum pre-rendered frames = 1" <--- is the important setting

> "Multi-display/mixed-GPU acceleration = Single display performance"

> "Power management mode = Prefer maximum performance"

> "Triple buffering = ON".

The rest of the settings should be left as Default.

 

Thanks for the Add! If I have any other issues I'll look into those settings! :D

 

Edit: looks like I needed to adjust the Nvidias settings, thanks a ton!!

Edited by CKNORTH
Link to comment
Share on other sites

Just to add to the OP tip about using compat mode , as compat modes if applied differently to launcher.exe and swtor.exe can cause issues. (they need to be using identical compat mode)

 

Simply try playing in fullscreen window mode if have stutters, this should fix the stutter issue

 

Also If using Nvidia card make the following change to the swtor.exe profile

 

go to "manage 3D settings" > "Program Settings" > "Add" (find the swtor.exe from the installed directory)

> "Maximum pre-rendered frames = 1" <--- is the important setting

> "Multi-display/mixed-GPU acceleration = Single display performance"

> "Power management mode = Prefer maximum performance"

> "Triple buffering = ON".

The rest of the settings should be left as Default.

 

Are there any AMD settings?

ie RX 480 and 3 screens.

Link to comment
Share on other sites

Are there any AMD settings?

ie RX 480 and 3 screens.

 

try the below for a AMD RX 480 +multiple monitors - original post

 

I'm running this below system and have none of the issues you are having in WZs. I'll try and help you with this, but I need to know what exact graphics settings do you have in the game.

 

i7 4790k

Sapphire RX 480 8gb nitro

16gb ram

Asus Maximus formula MB

Samsung 850pro SSDs

 

My FPS in WZs never goes below 60, but usually sits between 90-110fps

 

This is my AMD crimson settings if you want to try it out

Antialiasing mode - override application

Antialiasing level - 2xEQ

Antialiasing filter - standard

Antialiasing method - multisampling

Morphological filtering - off

Anisotropic filter mode - use application settings

Texture filter quality - high

Surface format optimisation- on

Vertical sync - off unless specified

OpenGL buffering - off

Shader cache - on

Tessellation - use application

Frame rate control - 160 FPS

 

Swtor settings

Vertical sync off

Resolution- 5760 x 1080

Bloom off

Conversation depth off

Texture quality high

Shader quality high

Antialiasing off

Character lvl detail high

Texture anisotropy high

Character texture atlasing high

Visible character limit very high

Shadow quality off

Shadow map cascades medium (but it's disabled anyway)

Grass render medium

Tree quality 20

Grass quality 20

Edited by OwenBrooks
Link to comment
Share on other sites

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.