Jump to content

One of my charecters no longer can load into game.


Recommended Posts

This issue only happens on one character and started today, if I click play as them the loading screen goes halfway and just stops, I let it sit for half an hour and it stayed halfway, the blue gear still turns, guild mates say it shows them login but the character doesn't appear, and every other character loads in fine, I have tried everything short of giving a friend the login info and moving me.


Follow up, I gave sibling the info and he has the exact same problem, so I know it is game side, not my computer.

Edited by Vektarulz
Link to comment
Share on other sites

Did you log out the character in a stronghold or a guild ship? That's happened sometimes in the past. If you can have someone else in the stronghold/guild ship while you try to log in, that may fix the problem.


Also, you should probably either send in a character stuck ticket (if you haven't already) and go to the customer service board for further assistance.

Edited by AscendingSky
Link to comment
Share on other sites

Exact same thing happened to me this week, here's what worked for me - your mileage may vary though.


Alt F4

Restart the game

Go to another server, log into a toon. Create one if you don't have one.

Log out, reopen your main server and log in.


Let me know if it works


just tried that, no luck, and earlier today I made new charecteron different server and same thing.

Link to comment
Share on other sites

  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.