Jump to content

Low FPS in Warzones - Update 3.0


vexxy

Recommended Posts

Hey guys,

 

Me and a couple of friends have decided to revisit SWTOR after 2 years, bought Revan, subscribed, leveled...all good...until we got into PvP. I'm not sure if this is a isolated problem with just us 3, but we have incredible low fps in any warzone. PvE works fine, the game runs almost flawless. But in PVP, it's simply unplayable, we get between 10-20 fps and it's pretty impossible to time your attacks. Basically, for us, PvP is unplayable.

 

My computer:

 

Windows 8, Intel i7-4930k (OCed to 4.5 Ghz), 32 gigs of RAM, SSD and 2 x nVidia 790 Ti on SLI.

 

I've tried the following, with no success:

 

- disabling the SLI, leaving 1 video card

- disabling the in-game shadows

- taking the game on LOW (gfx wise)

- repairing the game

- reinstalling the game

- added vsync with triple buffering

 

Now, I looked through various complaints in this forum and besides the ability delay issue, I'm not seeing many recent WZ performance complaints. On my side, there's little to do, I tried basically anything that's remotely related to the game. My next guess would be that the game has problems with Windows 8, but I'm not sure.

 

If we don't get this fixed, there's not much for us to do in-game since we're mainly PvPers and we started regreting coming back. Don't get me wrong, Im not here to whine, just looking for some advice or if somebody else has these issues. I haven't filled a report with support since I'm pretty sure how that'll turn up.

 

Thanks in advance

Link to comment
Share on other sites

See this devpost http://www.swtor.com/community/showthread.php?p=7936942#edit7936942

 

I went from 5-15 fps in warzones to 10-20 fps with 3.0.2 when they optimized the UI a bit. My computer is similar to yours but with a gti 980, more RAM and a six cored i7. The game has so low demand on my gfx that the gfx doesn't even start the fans.

 

If you read more into the dev post I'm pretty sure they don't have the knowledge to fix the several second ability delays, random fps drop to 5 fps for a few seconds, stuttering etc.

Link to comment
Share on other sites

Wierd. i having no issues when it comes to FPS. and i play a melee class running in middle

 

setup i7 4790k 4ghz clock, gtx 780 3 gb 16 gigs ram 1600

 

check if you have a virus program workig in backround when you play,. that couses lagg.

Link to comment
Share on other sites

with last patch they fixed everything for me...:)

 

I'd disable the antivirus, but it doesn't do me any problems in any others MMOs. Plus, the game works just fine outside the Warzones :(

 

Do you guys have WIn 7 or 8?

Link to comment
Share on other sites

See this devpost http://www.swtor.com/community/showthread.php?p=7936942#edit7936942

 

I went from 5-15 fps in warzones to 10-20 fps with 3.0.2 when they optimized the UI a bit. My computer is similar to yours but with a gti 980, more RAM and a six cored i7. The game has so low demand on my gfx that the gfx doesn't even start the fans.

 

If you read more into the dev post I'm pretty sure they don't have the knowledge to fix the several second ability delays, random fps drop to 5 fps for a few seconds, stuttering etc.

 

ya, i've read it and it saddened me. not sure if I should be optimistic or just move along :p

Link to comment
Share on other sites

  • 6 months later...

Well done. I just bought new computer.

 

Intel Core i5 4440 Haswell, RAM 8GB, AMD R9 270 2GB, Windows 7 64 bit.

 

Game is running on ultra settings with 60-120 fps. Depends on planet (makeb, rishi are probably worst, but it's ok and really enjoyable)

 

Warzones - 15-25 fps during fights. Unplayable (I tried lowest settings, doesnt help - same fps on every graphics setup) I tried Swtor unleashed, additional dx files. No change.

 

Any solutions? (Ofc i am subscriber )

Link to comment
Share on other sites

Old i7 2600k@4.1 GHz, 8gb of RAM and 980gtx here. All maxed but ShadowMapResolution = 2816 and custom forced AA. And my fps was almost the same with 780gtx - gg @ swtor engine devs! :rolleyes:

 

Okay... Have you tried Fullscreen Windowed (or whatever it calls in SWTOR) mode or "Run as admin" for SWTOR?

My fps in warzones is not outstanding but fairly good. 50+ fps most of the time.

 

I mean 30-40fps is really bad for me. Sometimes i can see 20 but it is very rare and everyone screams at same time in the chat i.e. must be server problems or "cheater" or something weird, not sure... :D

Edited by Glower
Link to comment
Share on other sites

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.