Jump to content

[Suggestion or bugfix] Heroic 2+ in Balmorra

Recommended Posts



I was doing some 2+ quests yesterday with some people and we were in a group of 4 people because we thought it was more fun to do so.


But when we were supposed to click some computer terminal in the quest "Republic's Last End" (or similar name) in Balmorra it only worked for two people.


We tried several times but it didn't work so I simply had to leave the group and go for a suicide mission where I did it all alone to get it complete while the others waited outside for me and the other guy to complete. The other guy just refused to do this quest and abandoned it because he was not happy with it.


The heroic 2+ quest I'm talking about is located at northern Balmorra at the research facility that's been swamped with alien creatures.




Link to comment
Share on other sites

We had a person joining us and he couldn't click it (you are talking about the quest: Project Hexapod), so we just finished our business, then went back out, he went in first and we followed.


And we did it again and got some nice drops overall too.


I don't get it why you would need to go on a suicide mission, when then can just join you?

Link to comment
Share on other sites

  • Create New...