Jump to content

[Bug] Denova HM

Recommended Posts

Reposted from Customer Support forum to see if anyone has the same bug/s.


Upon killing Toth ad Zorn, we left to repair, when we tried to get back in, it kept reloading us on the Rep Fleet ship.


EDIT: We decided to do a times run in Karragas Palace due to Denova being bugged. We wiped on Jarg and Sorna and everyone but myself, lost the timed buff. We then wiped on the Puzzle Droid and i lost the timed buff, but another person in the grp got theyres back.


I can only assume that only the last person to leave the instance (res) gets theyre buff back.



Upon completion of said times run, only the person with the active buff, recieved the title.




After clearing KP we decided to check on Denova again, to our suprise we could enter, so we decided to go inside and just grab the BH Comms and call it a night, after killing all the trash on the way to the box, the box remained red and unlootable.


The greoup leader did change to master looter befor ewe got to the box, dunno if that would mess it up or not.


Needless to say, alot of bugs this evening

Link to comment
Share on other sites

That was not the issue we faced, on the first boss (our first kill) a player died and ressed twice, which made his gear broken, he ported out to repair and then could no longer port back in. He just reloaded outside the instance every time he tried to enter.
Link to comment
Share on other sites

  • Create New...