Jump to content

Insane screen tearing


xSighKo

Recommended Posts

Why am I getting screen tearing at 110 fps????? Also my frames drop from 80+ to 40- in spaceports and other random areas. I know the graphics engine is bottlenecking but still screen tearing at 110 fps? I watched a pvp montage on youtube just now and the person was running on max settings and there was no tearing whatsoever so I know it's not the everyone this happens to. Edited by xSighKo
Link to comment
Share on other sites

Why am I getting screen tearing at 110 fps?????

Screen tearing is caused when the frame update from the game does not sync with the screen update. You will always have some form of tearing without Vsync enabled in this game.

 

Also my frames drop from 80+ to 40- in spaceports and other random areas.
This is due to the way player textures and other data is loaded. Not to mention there is just more stuff to draw. Everyone experiences this. Some suffer more than others.

 

I watched a pvp montage on youtube just now and the person was running on max settings and there was no tearing whatsoever so I know it's not the everyone this happens to.

Videos do not represent actual live play.

 

Enable Vsync in the game or experiment with setting a frame limit to minimize the tearing. Use google to learn how to accomplish these tasks.

Link to comment
Share on other sites

If you're running at 100+ fps, set your monitor refresh to 60 or so, then make sure the vertical sync box is checked. Your eyes can't even register more than 60 fps. If you're still having issues after that, make sure your drivers are up to date.
Link to comment
Share on other sites

You are wrong. Test it yourself or do some reading. Don't spout garbage you 'read on the internet'.

 

Most people can't tell the difference I know I can't. It really comes down to your eyes. But its obvious this guy doesn't ahve his settings right if he's seeing tearing.

 

VSync and making sure your refresh rate is correct should fix tearing.

Link to comment
Share on other sites

The only refresh rate I could choose is 60 and it was already set to that in the Nvidia panel and game settings. I'm using Vsynch+ triple buffering through the control panel since you can't triple buffer from an in game setting and it fixed the tearing. Also my eyes can't see a difference past 50 frames.Though with Vsynch on I can't go past 44. On another note the only problem now is the hitching but I know that can't be fixed since it's the game that is causing it.

 

Edit: Sitting next to this rock in Alderran puts me to 60 fps.

Edited by xSighKo
Link to comment
Share on other sites

×
×
  • Create New...