Jump to content

New SWTOR Forums are now live! ×

Camera Sensitivity is Out of Control


Wapner
 Share

Recommended Posts

Just like in the beta, the camera is literally uncontrollable. Even with the camera speed set to 1% it tough to control. At 50% it is laughable...moving my mouse 1cm literally spins the camera 20 times around my character. This is with my mouse (Razer Naga) at the lowest possible DPI. This was an issue in the beta, but I was hoping it would be fixed by now. This makes the game tough to play...not impossible, but I'd rather go play something else, with this issue. :( Video (keep in mind this is with very small movements of the mouse): [url]http://www.youtube.com/watch?v=3AiNVi-tdsw[/url] EDIT: Second video -- explained on second page: Set my DPI to my normal setting (1800) then moved the mouse about 3" slowly across my mouse pad. This is the result: [url]http://www.youtube.com/watch?v=2RC2hX4z6Qw[/url] Edited by Wapner
Link to comment
Share on other sites

  • Replies 291
  • Created
  • Last Reply

Top Posters In This Topic

Bump...forums moving too fast. It would be nice if there was a solution for this. :/ I'm not the type to usually say this, but I will honestly have to cancel my preorder on the 19th if this isn't fixed. :( As much as I truly enjoy every other aspect of the game, I can't pay $80 for a game that's frustrating to play. :(
Link to comment
Share on other sites

[quote name='Rulyen']I'm playing with a Naga as well, and have actually found the camera speeds to be a bit slower than I like. Have you checked in-game for any camera options you can change?[/QUOTE] Ya. In the video link you can see that I'm changing the camera speed. 50% is absolutely unplayable and 0% is difficult to play. :/ Unless there's another a setting I'm unaware of.
Link to comment
Share on other sites

[quote name='Rulyen']Do you have the Naga desktop control module on your PC? If so, please check your DPI. Mine is at 1800 and had no issues...[/QUOTE] Mine is at 800 DPI, with this issue. I normally play around 1800-2000 on most games. If I turn up the DPI to what I normally use, you can't even see anything on the screen...it's just one big swirling blur. This is not a hardware setup issue on my side, I can assure you of that. :) Edited by Wapner
Link to comment
Share on other sites

Greetings, I have been playing for about 4 hours now. I agree that camera control (the game view really) is tough: when I move it left or right, it seems to have a sort of "acceleration" lag then goes fast. I put it at around 15% with an ordinary mouse, and I'm basically moving the camera in an un-smooth motion here and there. I'm sure I'll get use to it, but it makes it difficult to have situation awareness. Will try : - getting better FPS (less graphics load) might improve camera smoothness. - increasing the camera distance (zoom out) for better perspective ( the game is brand new, and the animations are awesome, so I'll stick around.) Edited by Siriel
Link to comment
Share on other sites

[quote name='Siriel']Greetings, I have been playing for about 4 hours now. I agree that camera control (the game view really) is tough: when I move it left or right, it seems to have a sort of "acceleration" lag then goes fast. I put it at around 15% with an ordinary mouse, and I'm basically moving the camera is an un-smooth motion here and there. I'm sure I'll get use to it, but it makes it difficult to have situation awareness. Will try : getting better FPS (less graphics load) might improve camera smoothness. ( the game is brand new, and the animations are awesome, so I'll stick around.)[/QUOTE] I'm currently running the game at 100+ FPS with the graphics maxxed out. The camera is extremely smooth. It just moves insanely fast. :( I really wish that CM wouldn't have moved my post out of the customer support forums...I feel like it's not going to be seen much here. This is a technical issue, not a new player issue. If you check out the video, you'll see that at 0%, for me, the camera is still uncontrollably fast. This is with my mouse set to 800DPI, as well. EDIT: Also, zooming the camera out seems to exaggerate the issue, which is even further frustrating, because I like to play pretty far zoomed out. Not sure why game devs feel like they need to mess with mouse inputs. Just take raw input straight from Windows... Edited by Wapner
Link to comment
Share on other sites

[quote name='JamesPHoy']Is it possible to lock the camera view? I used to play CoH and could pick my camera angle and didn't have to bother controlling it unless I needed to adjust. Is that possible in this game?[/QUOTE] As far as I know, that isn't possible. But it wouldn't help my situation even if it were. I'm not a keyboard turner, so it would be extremely hard for me to play that way.
Link to comment
Share on other sites

[quote name='Rulyen']I'm playing with a Naga as well, and have actually found the camera speeds to be a bit slower than I like. Have you checked in-game for any camera options you can change?[/QUOTE] I'm not in yet but i was in beta for 9 months and if the OP is seeing anything like it was in the early beta (and i would not be shock if he was) then your Camera speed cant be to slow at max speed you can spin your camera around your toon 30 time EASY in 1/4th inch mouse move so fast everything will stretch into a blur and you will sir-pass the speed of light, breaking every law of physics making the universe as we know it crash in on it's self and destroy our very reality as we know it! so if its too slow you must be god P.S. hello god! Edited by Niquity
Link to comment
Share on other sites

To illustrate this issue further, I set my mouse to the DPI I play every othergame at (Rift, WoW, BF3, MW3, Skyrim.....the list goes on), which is 1800 DPI. I then went through a couple stages of camera speed. This is what I get, slowly moving my mouse about 3" across my mouse mat (it is moving faster than YouTube's 30FPS can give justice to. I can assure you the game is running at ~100FPS and is super smooth): [url]http://www.youtube.com/watch?v=2RC2hX4z6Qw[/url] I will keep this bumped until there is a solution, the thread is locked or I cancel my preorder on the 19th (or cancel it when the thread is locked).
Link to comment
Share on other sites

Just did some further troubleshooting on my own. Here's what I tried. 1) Swapped out my Razer Naga for my Razer Mamba (set at the same DPI) -- Not fixed 2) Updated drivers for both of my mice -- Not fixed 3) Played with graphical settings in-game (turned on/off vsync, changed to windowed mode, etc.) -- Not fixed 4) Went into the Windows 7 Mouse Properties and set the point speed to the absolute minimum (painfully slow...) It took me almost a minute to move my cursor across my screen... -- Slightly better, but not an acceptable solution. 5) Turned on/off SLI -- Not fixed 6) Tried an old school plain ol' Microsoft ball mouse -- Slightly better, but still hard to control (the only reason it's better is because the ball is far less sensitive) 7) Tried several different resolutions -- Not fixed 8) Tried with/without mouse pad, and with different types of pads (soft and metalic) -- Not fixed I'm at a loss. I've tried everything I can think of on my side of things. The CM moved the post out of customer support and into the noob forums, so I assumed he is telling me it's my fault and I'm doing something wrong. I sure can't find it.
Link to comment
Share on other sites

Surprised you have such problem with the Naga. I use it as well and its working like a charm like it always has been in other Games. I know that does not help you but it shows that others with same Mouse can Play with no problem. Hope you find out soon what it is. Regards
Link to comment
Share on other sites

[quote name='LordStark']Surprised you have such problem with the Naga. I use it as well and its working like a charm like it always has been in other Games. I know that does not help you but it shows that others with same Mouse can Play with no problem. Hope you find out soon what it is. Regards[/QUOTE] I can assure you it's not the mouse. The issue has occurred with 3 different mice now. I suppose it's possible that it's some hardware configuration I have (maybe my overclocked CPU, or maybe the particular video cards I have), but it's definitely not the mouse. It has something to do with the mouse acceleration on the camera (which Bioware is infamous for putting in all of their games). I would like to just outright disable it, and use raw mouse inputs. Whoever invented mouse acceleration should be taken out to a forest and shot. :P The main reason I'm fairly certain it is mouse acceleration is that the faster I move the mouse, the more drastic the effect becomes. I searched through all the files and found a .ini file, but it had nothing about mouse controls in it. The issue also seems to change based on several factors. At one minute it's fine, then after strafing if I face another direction quickly, it gets really bad. Other times it's just all around terrible with nothing to associate with it. I've also noticed quite a few times I'll be running along and looking around, then the camera will instantly face the sky or ground, even though I didn't move the mouse up or down... I'm not 100% certain what it is, but I'm pretty sure it's the software and not my system...otherwise I'd experience the problem in more than one game. Since the forum CM's insisted on moving my post out of the customer support forums, I have opened an in game ticket. Here's hoping that I actually get a reply. Edited by Wapner
Link to comment
Share on other sites

I have the same issue and so do 2 other people i play with, we all have different mice and hardware. It is crappy but the only thing u can do is set it to its lowest setting and try and get used to it. I play with my naga at 4800X 5000Y in all games and the camera moves about 4 times faster in SWTOR then any other game i play.
Link to comment
Share on other sites

not trying to jack your thread but i have the same issue i think - i use the naga mmo mouse with the 12 buttons on the side saem mouse? anyway i have mine set at 500 dpi and the camera is nutz - i came from galaxies where u could toggle the mouse mode - is that not possible in this game? how the hell are you supposed to move around with any accuracy?
Link to comment
Share on other sites

[quote name='Okishib']not trying to jack your thread but i have the same issue i think - i use the naga mmo mouse with the 12 buttons on the side saem mouse? anyway i have mine set at 500 dpi and the camera is nutz - i came from galaxies where u could toggle the mouse mode - is that not possible in this game? how the hell are you supposed to move around with any accuracy?[/QUOTE] I wouldn't consider this jacking my thread, since it's the exact issue I'm having. I have asked in the ticket if there's a way to disable the acceleration, or further lower the sensitivity (even if it's something more advanced like an INI tweak, I'm OK with that. Here's something interesting I just noticed: I obviously make videos, as you can probably tell from the youtube links and my channel :P....When recording the effect gets about 2x worse than when not recording. It is still too sensitive when running normally, though. This would lead me to believe it may have something to do with CPU usage multiplying the effect of the acceleration or something like that? The only thing that my recording software uses is the CPU and HDD's, that my game isn't even on. So I can't think of anything else.
Link to comment
Share on other sites

 Share

×
×
  • Create New...